use strict;
my $str = '{
type:"book",
author:["Willighagen, LG"],
editor:["Toos van Hoof","Karin Antoinette Henriette Majoor"],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}';
my $regex = qr/(("|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(")?([^":\n]+?)(")?\s*:/p;
my $subst = '$1"$5":';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";