#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$"
Local $sString = "http://regex101.com" & @CRLF & _
"http://regex101.com/" & @CRLF & _
"http://regex101.com/r" & @CRLF & _
"http://regex101.com/r/" & @CRLF & _
"http://regex101.com/r/FakeFakeFake" & @CRLF & _
"http://regex101.com/r/wY0rM7" & @CRLF & _
"http://regex101.com/r/wY0rM7/" & @CRLF & _
"http://regex101.com/r/wY0rM7/1" & @CRLF & _
"http://regex101.com/r/wY0rM7/11" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")