// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$").unwrap();
let string = "http://regex101.com
http://regex101.com/
http://regex101.com/r
http://regex101.com/r/
http://regex101.com/r/FakeFakeFake
http://regex101.com/r/wY0rM7
http://regex101.com/r/wY0rM7/
http://regex101.com/r/wY0rM7/1
http://regex101.com/r/wY0rM7/11
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}