import re
regex = re.compile(r"^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$", flags=re.MULTILINE)
test_str = ("http://regex101.com\n"
"http://regex101.com/\n"
"http://regex101.com/r\n"
"http://regex101.com/r/\n"
"http://regex101.com/r/FakeFakeFake\n"
"http://regex101.com/r/wY0rM7\n"
"http://regex101.com/r/wY0rM7/\n"
"http://regex101.com/r/wY0rM7/1\n"
"http://regex101.com/r/wY0rM7/11\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")