#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*"\s*([^ "]+)"\s*(?=[">])|(?<=")("")(?=")"
Local $sString = "<img src="imagename=g1" alt = "">" & @CRLF & _
"<img src="imagename="g1"" alt = """">" & @CRLF & _
"<img src="imagename="g1"" alt = ""abc"">"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)