$re = '/\s*"\s*([^ "]+)"\s*(?=[">])|(?<=")("")(?=")/';
$str = '<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = """">
<img src="imagename="g1"" alt = ""abc"">';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;