using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*""\s*([^ ""]+)""\s*(?=["">])|(?<="")("")(?="")";
string substitution = @"$1";
string input = @"<img src=""imagename=g1"" alt = "">
<img src=""imagename=""g1"" alt = """">
<img src=""imagename=""g1"" alt = ""abc"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}