use strict;
my $str = '<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = """">
<img src="imagename="g1"" alt = ""abc"">';
my $regex = qr/\s*"\s*([^ "]+)"\s*(?=[">])|(?<=")("")(?=")/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";