const regex = /\s*"\s*([^ "]+)"\s*(?=[">])|(?<=")("")(?=")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*"\\s*([^ "]+)"\\s*(?=[">])|(?<=")("")(?=")', 'g')
const str = `<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = """">
<img src="imagename="g1"" alt = ""abc"">`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);