import re
regex = re.compile(r"\s*\"\s*([^ \"]+)\"\s*(?=[\">])|(?<=\")(\"\")(?=\")")
test_str = ("<img src=\"imagename=g1\" alt = \"\">\n"
"<img src=\"imagename=\"g1\"\" alt = \"\"\"\">\n"
"<img src=\"imagename=\"g1\"\" alt = \"\"abc\"\">")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)