re = /\s*"\s*([^ "]+)"\s*(?=[">])|(?<=")("")(?=")/
str = '<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = """">
<img src="imagename="g1"" alt = ""abc"">'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result