import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\"\\s*([^ \"]+)\"\\s*(?=[\">])|(?<=\")(\"\")(?=\")";
final String string = "<img src=\"imagename=g1\" alt = \"\">\n"
+ "<img src=\"imagename=\"g1\"\" alt = \"\"\"\">\n"
+ "<img src=\"imagename=\"g1\"\" alt = \"\"abc\"\">";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}