# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\bsrc="[^ =]+=)"([^ "]+")"/$1$2/g;t' <<< "<img src=\"imagename=g1\" alt = \"\">
<img src=\"imagename=\"g1\"\" alt = \"\">"