re = /(\bsrc="[^ =]+=)"([^ "]+")"/
str = '<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = "">'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result