using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bsrc=""[^ =]+=)""([^ ""]+"")""";
string substitution = @"$1$2";
string input = @"<img src=""imagename=g1"" alt = "">
<img src=""imagename=""g1"" alt = "">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}