const regex = /(\bsrc="[^ =]+=)"([^ "]+")"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bsrc="[^ =]+=)"([^ "]+")"', 'g')
const str = `<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = "">`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);