import Foundation
let pattern = #"(\bsrc="[^ =]+=)"([^ "]+")""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = "">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)