#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\bsrc="[^ =]+=)"([^ "]+")""
Local $sString = "<img src="imagename=g1" alt = "">" & @CRLF & _
"<img src="imagename="g1"" alt = "">"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)