use strict;
my $str = '<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = "">';
my $regex = qr/(\bsrc="[^ =]+=)"([^ "]+")"/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";