#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "console.(log|debug|info|count)\((.*)\);?"
Local $sString = "console.log('test');" & @CRLF & _
"console.debug('test');" & @CRLF & _
"console.info('information);" & @CRLF & _
"www.google.com/console" & @CRLF & _
"console.count();" & @CRLF & _
"console.log('console');" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")