// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"console.(log|debug|info|count)\((.*)\);?").unwrap();
let string = "console.log('test');
console.debug('test');
console.info('information);
www.google.com/console
console.count();
console.log('console');
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}