using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"console.(log|debug|info|count)\((.*)\);?";
string input = @"console.log('test');
console.debug('test');
console.info('information);
www.google.com/console
console.count();
console.log('console');
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}