import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "console.(log|debug|info|count)\\((.*)\\);?";
final String string = "console.log('test');\n"
+ "console.debug('test');\n"
+ "console.info('information);\n"
+ "www.google.com/console\n"
+ "console.count();\n"
+ "console.log('console');\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}