package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`console.(log|debug|info|count)\((.*)\);?`)
var str = `console.log('test');
console.debug('test');
console.info('information);
www.google.com/console
console.count();
console.log('console');
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}