const regex = /console.(log|debug|info|count)\((.*)\);?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('console.(log|debug|info|count)\\((.*)\\);?', 'g')
const str = `console.log('test');
console.debug('test');
console.info('information);
www.google.com/console
console.count();
console.log('console');
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}