$re = '/console.(log|debug|info|count)\((.*)\);?/';
$str = 'console.log(\'test\');
console.debug(\'test\');
console.info(\'information);
www.google.com/console
console.count();
console.log(\'console\');
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);