re = /console.(log|debug|info|count)\((.*)\);?/
str = 'console.log(\'test\');
console.debug(\'test\');
console.info(\'information);
www.google.com/console
console.count();
console.log(\'console\');
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end