using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^comment[\s*:]*(.*)";
string substitution = @"\1";
string input = @"No of Host Probes : 0
Max no of Host Probes : 0
rstIsFailure : 1
state : UNKNOW
comment :
probe cycle errors : 0
Perf Callback Ids : None
Group Member : __jjjjkj - U0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}