# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^comment[\s*:]*(.*)"
test_str = ("No of Host Probes : 0\n"
"Max no of Host Probes : 0\n"
"rstIsFailure : 1\n"
"state : UNKNOW\n"
"comment : \n"
"probe cycle errors : 0\n"
"Perf Callback Ids : None\n"
"Group Member : __jjjjkj - U0")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.