import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^comment[\\s*:]*(.*)";
final String string = "No of Host Probes : 0\n"
+ "Max no of Host Probes : 0\n"
+ "rstIsFailure : 1\n"
+ "state : UNKNOW\n"
+ "comment : \n"
+ "probe cycle errors : 0\n"
+ "Perf Callback Ids : None\n"
+ "Group Member : __jjjjkj - U0";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}