re = /^comment[\s*:]*(.*)/m
str = 'No of Host Probes : 0
Max no of Host Probes : 0
rstIsFailure : 1
state : UNKNOW
comment :
probe cycle errors : 0
Perf Callback Ids : None
Group Member : __jjjjkj - U0'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result