const regex = /^comment[\s*:]*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^comment[\\s*:]*(.*)', 'gm')
const str = `No of Host Probes : 0
Max no of Host Probes : 0
rstIsFailure : 1
state : UNKNOW
comment :
probe cycle errors : 0
Perf Callback Ids : None
Group Member : __jjjjkj - U0`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);