import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"market_listing_price market_listing_price_with_fee\\\\\">[\\\\r]*[\\\\t]*&";
final String string = "<span class=\\\"market_listing_price market_listing_price_with_fee\\\">\\r\\t\\t\\t\\t\\t$92.53 USD\\t\\t\\t\\t<\\/span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}