import Foundation
let pattern = #""market_listing_price market_listing_price_with_fee\\">[\\r]*[\\t]*&"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<span class=\"market_listing_price market_listing_price_with_fee\">\r\t\t\t\t\t$92.53 USD\t\t\t\t<\/span>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}