// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""market_listing_price market_listing_price_with_fee\\">[\\r]*[\\t]*&"#).unwrap();
let string = "<span class=\\\"market_listing_price market_listing_price_with_fee\\\">\\r\\t\\t\\t\\t\\t$92.53 USD\\t\\t\\t\\t<\\/span>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}