re = /"market_listing_price market_listing_price_with_fee\\">[\\r]*[\\t]*&/
str = '<span class=\\"market_listing_price market_listing_price_with_fee\\">\\r\\t\\t\\t\\t\\t$92.53 USD\\t\\t\\t\\t<\\/span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end