# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+\s*([A-Z](?![A-Z]))?)//g;t' <<< "80 A N A D D R E S S W I T H T O O M A N Y S P A C E S
A 80 A
80 ROSE COTTAGE"