const regex = /(\d+\s*([A-Z](?![A-Z]))?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\s*([A-Z](?![A-Z]))?)', 'g')
const str = `80 A N A D D R E S S W I T H T O O M A N Y S P A C E S
A 80 A
80 ROSE COTTAGE`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);