re = /(\d+\s*([A-Z](?![A-Z]))?)/
str = '80 A N A D D R E S S W I T H T O O M A N Y S P A C E S
A 80 A
80 ROSE COTTAGE'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result