#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+\s*([A-Z](?![A-Z]))?)"
Local $sString = "80 A N A D D R E S S W I T H T O O M A N Y S P A C E S" & @CRLF & _
"A 80 A" & @CRLF & _
"80 ROSE COTTAGE"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)