import Foundation
let pattern = #"(\d+\s*([A-Z](?![A-Z]))?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
80 A N A D D R E S S W I T H T O O M A N Y S P A C E S
A 80 A
80 ROSE COTTAGE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)