using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\s*([A-Z](?![A-Z]))?)";
string substitution = @"";
string input = @"80 A N A D D R E S S W I T H T O O M A N Y S P A C E S
A 80 A
80 ROSE COTTAGE";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}