import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\s*([A-Z](?![A-Z]))?)";
final String string = "80 A N A D D R E S S W I T H T O O M A N Y S P A C E S\n"
+ "A 80 A\n"
+ "80 ROSE COTTAGE";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}