use strict;
my $str = '80 A N A D D R E S S W I T H T O O M A N Y S P A C E S
A 80 A
80 ROSE COTTAGE';
my $regex = qr/(\d+\s*([A-Z](?![A-Z]))?)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";