using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<img.*?width=\""(.*?)\"".*?\/?\>";
string substitution = @"";
string input = @"<img asdasd width=""234.4""hjbsd>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}