import Foundation
let pattern = #"\<img.*?width=\"(.*?)\".*?\/?\>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img asdasd width="234.4"hjbsd>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)