re = /\<img.*?width=\"(.*?)\".*?\/?\>/
str = '<img asdasd width="234.4"hjbsd>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result