#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\d+(\s*,\s*\d+)*|\bs\..*$"
Local $sString = "Lorem ipsum 12, 14" & @CRLF & _
"Lorem 29" & @CRLF & _
"34" & @CRLF & _
"Lorem s. anything" & @CRLF & _
"vcbvcbv"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)