using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(\s*,\s*\d+)*|\bs\..*$";
string substitution = @"";
string input = @"Lorem ipsum 12, 14
Lorem 29
34
Lorem s. anything
vcbvcbv";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}