package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\d+(\s*,\s*\d+)*|\bs\..*$`)
var str = `Lorem ipsum 12, 14
Lorem 29
34
Lorem s. anything
vcbvcbv`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}